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Audience 
This document is for the MDL Tech Com End-User group. 

 

 

How to Use this Document 
• Read the Standard Operating Procedure once, if you have time. 

• Use the Quick Start in Appendix B when you begin writing HTML 
files for help projects. 

• Refer to the HTML Gotchyas report on an as needed basis. 
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Standard Operating 
Procedures 
How to create HTML files for help projects 
using Front Page 
Below is a complete step-by-step guide, with detailed explanations and 
pictures, for creating HTML files that will work well with your style sheet. 

If you want a quick reference, see Appendix B. 

Standard Operating Procedures - Complete 

1. Use a clean file. In FrontPage, select File > New. 

2. Type the text into the file without applying any formatting 
whatsoever.  No headers, no bullet points, and so on. 
 
Below is a picture of a vanilla HTML page.  No formatting has been 
applied.  The style sheet has not been linked. 

 

 
 



 

Here is what the HTML for this page looks like. 

 

Notice that all the text is 
enclosed in <p> tags, 
even items that will be 
headers and lists. 

3. Attach the style sheet to the page. (Format > Style Sheet Links) 

4. Save the page, if necessary. 
 
Here is what the page looks like with the style sheet applied.  Notice 
that the font has changed to Arial and the background color is now 
light yellow. 
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When we look at the HTML, notice that the only change is that a <link> tag 
has been added.  The sentences that read “This is a Header 1,” “This is a 
Header 2” and so on are still enclosed with <p> tags, which means the 
paragraph formatting is applied to them. 

 

The style sheet has been 
linked to the HTML document, 
but everything else is the 
same. The headers and lists 
still have the <p> tags and so 
take on the <p> formatting as 
defined by the style sheet. 

5. In Normal view, put your cursor on the line that you want to format.  
For example, you want the line “This is a Header 3” to have the 
Heading 3 format, so you would place your cursor on that line. 

6. Select the appropriate HTML selector from the style drop-list.  The 
style drop-list is located on the formatting toolbar in FrontPage. 

             

HTML selectors have 
a ¶ in front of them.  

Classes have nothing 
in front of them.  

 
 



 

Note: Styles for HTML selectors and classes are available from the 
style drop-list once the style sheet has been applied to the 
document.  The HTML selectors have a ¶ symbol in front of them 
and classes have a blank space in front of them. 
The distinction between selectors and classes and how to apply 
them via the WYSIWYG editor are described in the section 
“Applying Classes” on page 13. 

Here is what the page looks like with the heading formats applied to it: 
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And below is the HTML for the page.  Notice that the sentences which refer to 
headers are no longer enclosed by <p> tags, but with the appropriate <h> tags 
(for example, h1, h2, h3, and so on). 

 

The heading styles have now 
been applied to the items that 
will be the headers.  Notice 
that in the Normal view the 
headers are bold and larger 
than the paragraphs, but that 
no weight, font, or size 
information has been added 
to the <h> tags. 

 

7. Repeat steps 5-6 until you have applied selector styles to all sections 
that need them. 

8. Apply classes, where necessary, after you have applied selector 
styles. 

a. Place your cursor on the line that you want to apply a class to. 

 
 



 

b. Select the appropriate class from the style drop-list. Note: 
classes do not have a ¶ in front of them in the style drop-list. 

c. Repeat steps a-b until you have applied classes to all sections 
that need them. 

9. Make individual words in paragraphs bold by selecting the word(s) 
and pressing Ctrl+B. 

10. Some don’ts to keep in mind: 

a. Don’t select fonts from the formatting toolbar. 

b. Don’t set font size from the formatting toolbar. 

c. Don’t set margins by pressing the space bar. 

d. Don’t increase space between paragraphs, lists, or headers by 
pressing the Enter key. 

e. Don’t decrease space between paragraphs, lists, or headers by 
pressing Shift+Enter. 

f. Don’t set page preferences by selecting File > Properties. 

g. Don’t layout pages, paragraphs, or lists with tables. 

h. Don’t select <h> styles at random. Be sure you know which 
headings are used in your CSS and style guide. 

 

 
 

Special Formatting Situations 

The following sections describe  

• Applying classes 

• Formatting bulleted lists 

• Creating alpha-numeric, outline-style lists 

• Formatting text in tables 
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Applying Classes  

Apply classes after you have applied styles. Applying styles first may prevent 
you from applying or inadvertently copying unnecessary formatting to other 
paragraphs, headings, and so on. 

 

Example: You need to change the spacing between a paragraph and a list that 
follows it.   
 

 

Each paragraph has the same 
amount of space between 
them. In our example, we 
want to decrease the space 
between the last paragraph 
and the bulleted list, but keep 
the spacing between 
paragraphs as is. 

 

 
In your style sheet, create a class that sets a short bottom margin. (For 
example: .prelist {bottom-margin: 6px;}) Save the style sheet. This class is 
now available in the style drop-list in the WYSIWYG editor. Apply this class 
to the paragraph before the list. 

 
 



 

In the picture below, a class called prelist has been applied to the paragraph 
that precedes the bulleted list.  This class sets a small bottom margin, thereby 
reducing the space between the paragraph and the following list.  This class 
was applied by selecting the prelist class from the style drop-list.   

 

 

Applying the prelist class 
to this paragraph 
decreased the space 
between the paragraph 
and the following list. 
 
Compare to the preceding 
picture. 

 

Are the classes postlist and prelist “standards”?  No.  Classes can 
be named anything you want and defined any way you want. Nicki 
and I chose these names because we thought they were clear. 

 

What is the difference between “styles” and classes? 
Actually, the terms should be HTML selectors and classes, with styles or, 
rather rules, being something applied to both.  For our purposes here, we are 
calling “styles” any style that defines particular HTML selectors, such as p, 
h3, and li. The style sheet sets rules for how text in <p> tags will display, for 
example.  

Classes are “free agents” and can be used within different types of HTML tags 
to change a particular paragraph, heading, or list. For example, a class such as 
prelist above can change the spacing of paragraphs that come before lists.  In 
HTML, the class would be applied like so: 

<p class=”prelist”>Paragraph text here.</p> 

Remember: once a style sheet is linked to a document, both “styles” and 
classes can be applied via the style drop-list. 
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Formatting Bulleted Lists 

The bulleted lists in our example have been formatted by applying the Menu 
style to each line.  The indented bulleted lists have been formatted by 
applying the Bullet style to each line. 

Is the Bullet style inherently indented?  No, it isn’t.  Both the Menu 
and Bullet styles have their margins set in the style sheet or not, 
depending on the style sheet. Use the appropriate style as defined 
by your particular style sheet. 

 

Below is a picture of the page with the formatted bulleted lists. 

             

 
 



 

 

Creating Alpha-Numeric Outline-Style Lists 

Here is an example of an alpha-numeric, outline-style list  

1. Have lunch. 
2. Go to the beach. 

a. Put on suntan lotion. 
b. Read book. 
c. Bask in sunshine. 

3. Drive home 

FrontPage is not able to apply indented, outline-style numbers (or letters) via 
the Style drop-list. Instead, you can create outline-style lists using the Format 
> Bullets and Numbering menu or by editing the HTML.  Below I describe 
both methods. 

Why creating alpha-numeric lists via the style drop-list does not 
work. Here is the test I performed with FrontPage: I created a 
class called alpha, which when added directly to the <ol> tag (the 
ordered list tag), creates an indented list that orders items using 
lower case letters (e.g. a, b, c, and so on). Applying the alpha class 
to the Numbered Style (found in the style drop-list) creates an 
indented list that uses a number instead of a letter. The HTML 
shows that the alpha class is not applied to a new <ol> tag, and 
instead creates a <p> tag with the alpha class: <p 
class=”alpha”>.  This HTML, of course, will not create an outline-
style ordered list. 

Using the WYSIWYG Editor 
You can create outline-style alpha-numeric lists by selecting the Numbered 
List style for the top-level hierarchy.  To create the second-level items, put 
your cursor on the line to indent, click the Increase Indent button two times, 
and then select Format > Bullets and Numbering > Numbers. Use the List 
Properties dialog to set formatting (e.g. letters, Roman numerals, and so on). 

Writing the HTML  
To create an alpha-numeric list similar to the beach example above 

1. Put your cursor on the line that will be the first item in the top-level 
hierarchy. 

2. Select the Numbered List style from the Style drop-list menu to create 
the top-level hierarchy. 
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3. To create the second-level item, place your cursor on the line that you 
want to indent. 
 
In the picture below, you would put your cursor on the line that reads, 
“Indented numbered item 1.” 
 

 

4. Click on the HTML tab in FrontPage. 

5. Before the indented list, type <ol class=”alpha”> (or, instead of 
alpha, use the appropriate class as defined by your style sheet). 
 

 

Type: <ol class=”alpha”> 
here on the empty line. 

6. Replace the <p> tags with <li> tags. 

7. Replace the </p> tags with </li> tags. 

8. End the ordered list by typing </ol> on the line below the last 
indented item.  

 
 



 

Your HTML should look like the following: 
 

 
 

9. Click the Normal tab in FrontPage.   
 
You should see a picture similar to the following: 
 

 

10. To continue numbering with the non-indented numbering (for 
example, restarting the list above with number 3), you will need to: 

a. Click the HTML tab in FrontPage. 

b. Before the spot where you want the numbering to restart, type 
<ol start=”#”> where # is the number you want to start 
with. 

c. Replace the <p> tags with <li> tags. 

d. Replace the </p> tags with </li> tags. 

e. End the list by typing </ol> on the line below the last indented 
item. 
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Continuing with our example, your HTML should look like so:  

         
 
Here is the page in Normal view: 

 

 

Which Method Should You Use? 
I recommend applying classes via HTML. Why?  If you apply the class 
information, you can affect the margins and font information via the style 
sheet. 

Furthermore, clicking the Increase Indent or Decrease Indent buttons to 
change the list hierarchy doesn’t always work and when it does, it tends to 
create “junky” HTML. In my tests, the opening <ol> tags and sometimes the 
closing </ol> tags were missing. 

 
 



 

 

Formatting Text in Tables 

In general, do not use tables  

• To layout pages.  

• To format regular or specially indented paragraphs.   

• To format lists. 

Style sheets should be used instead of tables in the instances described above. 

A complete description of how to format tables using CSS is beyond the scope 
of this SOP. The following sections describe generally how to format text in 
tables. For a fuller sense of how to add padding, spacing, alignment, borders, 
and other table and cell properties, see the style sheet in Appendix A. 
 

Formatting Column Headers 
To format column headers, define a rule for the <th> tag.  

Example: In your style sheet, define a rule for <th> tags like so: 

th { font-size: 12pt;  
       font-weight: bold; } 

Your HTML mark-up should look similar to the following: 

<table> 
    <thead> 
        <th>Column Heading 1</th> 
        <th>Column Heading 2</th> 
        <th>Column Heading 3</th> 
     </thead> 

When the style sheet with the information above is applied to the file, any text 
in <th> tags will be bold and 12 pt. 
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Formatting Row Headers 
To format a particular style for row headers, define a class in the style sheet, 
select the cells that are to become row headers, and apply the class via the 
style drop-list. 

Selecting the cells before applying the class information applies 
class information to the <td> tag. If you select the text only (in 
Normal view), a <p> tag is added to the table with the class 
information in it like so: <p class=”rowhead”>. A <p> tag in the 
table means that text in the table cells will take on the formatting 
features of regular paragraphs.  Adding class information to the 
<td> tags is more efficient and “cleaner.”  

 

Formatting Table Cells 
To format the text size in individual table cells, define a rule for the <td> tag.  

As of this writing, <td> tags do not use the font-size defined in the 
<body> tag. A font-size must be specified for the <td> tag. 

Example: In your style sheet, define a style for <td> tags like so: 

td { font-size: 10pt; } 

When the style sheet with the information above is applied to the file, any text 
in tables will be 10 pt. 

 
 



 

 

Still Have Formatting Problems? 

Fix formatting problems (such as spacing, for example) in the style sheet, not 
in the HTML document. 
 
Example: Below is the text with the styles applied to it. More space needs to 
be added before the headers and less after.  Do you fix the spacing here by 
pressing the Enter key, for instance?  No.  Fix spacing in the style sheet.   

Of course, be sure you have the agreement of the style sheet 
“owner” before making any changes to the style sheet as changes 
made to the style sheet affect all pages that reference it. 

 

 

This page has equal spacing 
before and after headers. 
 
We want to increase the space 
before the headers and decrease 
the space after them. 
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Before changing the spacing information in the style sheet, take a look at the 
HTML. 

 

No spacing or margin 
information is in the <h> 
tags. 

 

 
 



 

 

 

Change the margins of all the headers in the style sheet. Here is the same page 
in Normal view after the margins were changed in the style sheet.  The 
headers are now closer to the paragraphs that follow them and further from the 
preceding paragraphs. 

 

The space before headers 
has increased and the 
space after the headers 
has decreased. 

 

And what does the HTML look like?   
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It looks exactly the same. Notice that there is no formatting information in the 
tags.  Also, there are no font, span, or div tags. 

The <h> tags are exactly 
the same.  No margin or 
spacing information has 
been added to them.  Only 
the style sheet changed! 

 
 



 

 

Appendix A: The Style Sheet 

For the curious and adventuresome, this section has the style sheet that was 
used in this SOP. The style sheet is fully commented. The rules are written out 
in long-hand for ease of understanding. Examples of how to mark-up your 
HTML to use a particular style or class are given when necessary.  

/*This style sheet was created for the Standard Operating Procedures Guide 
for creating clean mark-up. It was adapted from Frank Ripp’s original style 
sheet so that it looks familiar to the team. 
  Author: Kira Reoutt 
  Date: June 2004 
  */ 
 
/* This is the BODY style. It defines the background color and sets the font 
type and size. */ 
body { 
 font-family: Arial, Helvetica, sans-serif; 
 font-size: 10pt; 
 background-color: ffffe1; 
} 
 
/* This is the HEADING 1 style */ 
h1 { 
 font-size: 18pt; 
 font-weight: bold; 
 margin-top: 2px; 
 margin-bottom: 3px; 
} 
 
/* This is the HEADING 2 style */ 
h2 { 
 font-size: 14pt; 
 font-weight: bold; 
 margin-top: 18px; 
 margin-bottom: 3px; } 
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/* This is the HEADING 3 style */ 
h3 { 
 font-size: 12pt; 
 font-weight: bold; 
 margin-top: 16px; 
 margin-bottom: 3px; } 
 
/* This is the HEADING 4 style */ 
h4 { 
 font-size: 10pt; 
 font-weight: bold; 
 margin-top: 14px; 
 margin-bottom: 3px;  
} 
 
/* This style is for regular PARAGRAPHS */ 
p { 
      margin-top: 0px; 
      margin-bottom: 10px; 
} 
 
/* This class is for Paragraphs BEFORE LISTS. It reduces the space between 
a paragraph and the following list.  
Use it in the <p> tag like so:  
<p class="prelist">Paragraph text here.</p>   
*/ 
 
.prelist { 
 margin-bottom: 6px ; 
} 
 
/* This class is for Paragraphs AFTER LISTS.  It increases the space between 
the last item in a list and the following paragraph. 
Use it in the <p> tag, for example, like so:  
<p class="postlist">Paragraph text here.</p>  



 

 */ 
 
.postlist { 
 margin-top: 12px ; 
} 
 
/*This class INDENTS every line in the paragraph. 
Use it in the <p> tag  like so:  
<p class="ind">Paragraph text here.</p>   
*/ 
 
.ind { 
 margin-left: 20px ; 
} 
 
/*This class is for FIRST LINE INDENTED paragraphs.  It indents the first 
line of a paragraph.  
Use it in the <p> tag like so:  
<p class="first">Paragraph text here.</p>   
*/ 
 
.first { 
 text-indent: 20px ; 
} 
 
/*This class is for HANGING INDENTS in paragraphs. 
Use it in the <p> tag like so:  
<p class="hang">Paragraph text here.</p>   
*/ 
 
.hang { 
 text-indent: -20px ; 
 margin-left: 20px; 
} 
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/* This style is called MENU LIST in the style drop-list.  
Use it as the first-level bulleted list in a hierarchical list. */ 
menu { 
 margin-top: 4px; 
 margin-bottom: 12px; 
 margin-left: 24px; 
} 
 
/* This style is called BULLETED LIST in the style drop-list.  
Use it as the second-level bulleted list in a hierarchical list. */ 
ul { 
 margin-top: -9px; 
 margin-bottom: 4px; 
 margin-left: 40px; 
} 
 
/*This style is for LIST ELEMENTS, whether they are numbers or bullets.  
It sets the spacing between bulleted or numbered items.*/ 
li { 
    margin-bottom:  4px ; 
} 
 
/* This is the first or top-level NUMBERED list style.   
Use it for the top level hierarchy in a hierarchal alpha-numeric list. */ 
ol { 
 margin-top: 0px; 
 margin-bottom: 12px; 
 margin-left: 28px; 
} 
 
/* This class is for second-level ALPHA-NUMERIC lists. 
Use it for the second-level hierarchy in a hierarchal alpha-numeric list. 
Use it in the <ol> tag like so:  
<ol class="alpha">  
       <li>List item 1</li>  



 

       <li>List item 2</li> 
</ol>  
*/ 
.alpha { 
 margin-top: -9px; 
 margin-bottom: 12px; 
 margin-left: 54px; 
 list-style: lower-alpha ;  
} 
 
/* This style applies to TABLES */ 
table { 
 width: 100% ;  
 cellspacing: 0; 
 border-collapse: collapse; 
} 
 
/*This style is for COLUMN HEADERS in tables  
 This style applies when the first “row” of the table is marked-up like so: 
<table>  
  <thead> 
       <th>Column Heading 1</th> 
       <th>Column Heading 2</th> 
       <th>Column Heading 3</th> 
  </thead> 
  */ 
 
thead th { 
    font-size: 12pt; 
    font-weight: bold; 
    vertical-align: bottom; 
    text-align: left; 
    padding-top: 2px;   
    padding-right: 4px; 
    padding-bottom:  4px;   
    padding-left: 4px; 

  30 
 



. . . . . . 

. 

.. . 

 

  31 
 

 

     
 
   height: 18px; 
    border-width: 1px; 
    border-style: solid; 
    border-color: #666666 ;        
    } 
 
/*This class is for ROW HEADERS in tables  
Use it in the <td> tags in the first column like so:  
<td class="rowhead">Row Header Here</td>   
*/ 
.rowhead { 
    font-size: 12pt ; 
    font-weight: bold ; 
    } 
 
/* This style is for text in TABLE CELLS.  
Note that the width is specified as 25%. This is for a 4 column table with a 
100% width, which means the table will span across the width of the screen or 
page. */ 
td { 
      font-size: 10pt; 
      border-width: 1px; 
 border-style: solid; 
 border-color: #666666 ;    
      width: 25%; 
 alignment: left; 
 vertical-align: top; 
 height: 30px; 
 text-align: left ; 
 padding: 4px; 
} 
 



 

 
Appendix B: Standard Operating Procedures Quick Start 

The steps in this quick start are the same as in the Standard Operating 
Procedures, only the pictures and explanations have been removed. 

 
1. Use a clean file.  In FrontPage, select 

File > New. Ideally, this file has none of 
the problems described in the HTML 
“Gotchya” Report. 

2. Type the text into the file without 
applying any formatting whatsoever.  No 
headers, no bullet points, and so on. 

3. Attach the style sheet to the page. 
(Format > Style Sheet Links) 

4. Save the page, if necessary. 

5. In Normal view, put your cursor on the 
line that you want to format.   

6. Select the appropriate selector style from 
the style drop-list. The style drop-list is 
located on the formatting toolbar in 
FrontPage. 

7. Repeat steps 5-6 until you have applied 
selector styles to all the sections that 
need them. 

8. Apply classes, where necessary, after 
you have applied selector styles. 

a. Put your cursor on the line you want 
to apply a class to. 

b. Select the appropriate class from the 
style drop-list. Note: classes do not 
have a ¶ in front of them in the style 
drop-list. 

c. Repeat steps a-b until you have 
applied classes to all sections that 
need them. 

9. If necessary, make individual words in 
paragraphs bold by selecting the word(s) 
and pressing Ctrl+B. 

 

10. Some don’ts to keep in mind: 

a. Don’t select fonts from the formatting 
toolbar. 

b. Don’t set font size from the formatting 
toolbar. 

c. Don’t set margins by pressing the space 
bar. 

d. Don’t increase space between 
paragraphs, lists, or headers by pressing 
the Enter key. 

e. Don’t decrease space between 
paragraphs, lists, or headers by pressing 
Shift+Enter. 

f. Don’t set page preferences by selecting 
File > Properties. 

g. Don’t layout pages, paragraphs, or lists 
with tables. 

h. Don’t select <h> styles at random. Be 
sure you know which headings are used 
in your CSS and style guide. 

11. Still have formatting problems? Try one of 
the following: 

• Go over the following sections in 
Standard Operating Procedures 
• Applying Classes 
• Formatting Bulleted Lists 
• Creating Alpha-Numeric, Outline-

Style Lists 
• Formatting Text in Tables 

• Still have formatting problems?  
• Go through the HTML 

”Gotchyas” Report. Review 
the TOC and see if your 
particular problem is listed 
there. 
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